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'Unable to Authenticate Your Payment Method' Error

Resolve the 'We are unable to authenticate your payment method' error, which appears when a tenant uses an unsupported payment method like an international card or FSA card.

Written by Samuel

The "We are unable to authenticate your payment method. Please choose a different payment method and try again" error appears when the payment method the tenant is trying to use is not supported by the system.

Common Causes

  • International bank account or credit card

  • FSA (Flexible Spending Account) card

  • Other unsupported card types

How to Fix It

The tenant needs to use a different, supported payment method. Accepted methods include credit/debit cards (US-issued), ACH bank transfer, Apple Pay, Google Pay, and CashPayments by Western Union.


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